Debian, Information, Linux Distributions, OpenSourceSoftware, Security, Sguil, Ubuntu

Sguil on Ubuntu 10.04 LTS (Lucid Lynx)

As Ubuntu 10.04 (Lucid Lynx) is the next LTS (Long Time Support) version of Ubuntu that is coming out soon (April 29, 2010), I have started to look at how sguil and my dot deb packages will work.

I installed Lucid Lynx yesterday and installed my server and sensor debs on it.

Some first notes:

* MySQL is not eating the create_sguildb.sql (Just remove the comments)
* Lucid (and Karmic) does not ship with tclx8.3 😦 (Installing the Hardy version worked just fine)

(I filled a bug report to Ubuntu, hoping to get tclx8.3 into the final release…)

So, from my first tests, it seems to work fine!

I have yet to test the sguil-client on Lucid, and also I did not get to test with extensive amount of traffic and operations on the Lucid test server.

So, looking promising 🙂

Advertisements
Standard

2 thoughts on “Sguil on Ubuntu 10.04 LTS (Lucid Lynx)

  1. peng says:

    Hi,
    im facing some problem with sguil-sensor installation on 10.04.

    Error msg
    ======================================
    The following extra packages will be installed:
    pads
    The following packages will be upgraded:
    pads
    1 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
    1 not fully installed or removed.
    Need to get 0B/108kB of archives.
    After this operation, 0B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    (Reading database … 47155 files and directories currently installed.)
    Preparing to replace pads 1.2-1 (using …/archives/pads_1.2-10_amd64.deb) …
    * Stopping Passive Asset Detection System pads
    …fail!
    invoke-rc.d: initscript pads, action “stop” failed.
    dpkg: warning: old pre-removal script returned error exit status 1
    dpkg – trying script from the new package instead …
    * Stopping Passive Asset Detection System pads
    …fail!
    invoke-rc.d: initscript pads, action “stop” failed.
    dpkg: error processing /var/cache/apt/archives/pads_1.2-10_amd64.deb (–unpack):
    subprocess new pre-removal script returned error exit status 1
    update-rc.d: warning: /etc/init.d/pads missing LSB information
    update-rc.d: see
    * Starting Passive Asset Detection System pads
    Segmentation fault
    …fail!
    invoke-rc.d: initscript pads, action “start” failed.
    dpkg: error while cleaning up:
    subprocess installed post-installation script returned error exit status 139
    Errors were encountered while processing:
    /var/cache/apt/archives/pads_1.2-10_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    ============================================

    please advise 🙂

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s